OBM File Backup errors on OneDrive Folder with Files On-Demand enabled
Article ID
Last Reviewed Date
Product Version
Operating System
Symptom
When performing a file backup on a OneDrive folder with Files On-Demand enabled, the following error message is received in the backup report:
| No. | Type | Timestamp | Log | 
|---|---|---|---|
| info | |||
| erro | |||
| * | info | ... | ... | 
| * | erro | YYYY/MM/DD hh:mm:ss | [New File] File="C:\Users\username\ folder\file" Error="java.io .IOException: [ReadFile] (381) The cloud operation is not supported on a read-only volume... | 
Or
| No. | Type | Timestamp | Log | 
|---|---|---|---|
| info | |||
| erro | |||
| * | info | ... | ... | 
| * | erro | YYYY/MM/DD hh:mm:ss | [New File] File="C:\Users\username\ folder\file" Error="java.io .IOException: [CreateFileW] (395) Access to cloud file is denied... | 
Cause
When the "Files On-Demand" is enabled for your OneDrive folder, it saves disk space by not saving the file on the computer, instead, new files created online or on another device appear as online-only files in File Explorer.
Resolution
To resolve the issue, there are a few options:
- Option 1 
 Disable the File On-Demand option. Note that this will increase the disk space usage on the affected client computer.- Click Here for details on how to disable the option. 
- Option 2 
 Unselect the OneDrive folder from the backup source of the affected backup set.- Create a new Cloud File Backup set to backup the OneDrive data.  
- Option 3 
 Update the AhsayCBS server and AhsayOBM / ACB client software to the latest versions.- Click Here for instructions on how to update AhsayCBS. - Click Here for instructions on how to update AhsayOBM / ACB. - You may, alternatively, apply hotfixes to AhsayCBS and AhsayOBM / ACB. Click on the links below to access the latest hotfixes available for v8 and v9. (Access to Ahsay Partner Portal is required) - For instructions on how to apply hotfixes to AhsayCBS and AhsayOBM / ACB, you may click here and here respectively. 
